Can't Install Mac Provisioning Profiles

Forums Programming cocos2d Mac Can't Install Mac Provisioning Profiles

This topic contains 5 replies, has 3 voices, and was last updated by  hermesdavidms 2 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
Author Posts
Author Posts
August 10, 2011 at 7:05 am #234187

dar
Participant
@dar

When I download a mac provisioning profile, it can’t be recognized by Xcode and cannot be installed. Do I need to use Xcode 4 to install it? I am now using Xcode 3.2.5 on Snow Leopard.

August 10, 2011 at 8:45 am #342879

clarus
Moderator
@clarus

The version shouldn’t matter– just drag them to the Xcode app icon. I’ve never seen that fail.

August 10, 2011 at 10:27 am #342880

dar
Participant
@dar

I have dragged it into the Xcode app icon but nothing happened. The icon of my mac provisioning profile is blank, which is different from the ios provisioning profiles which has an icon with “PROV”. I think there is something wrong here.

August 10, 2011 at 6:03 pm #342881

clarus
Moderator
@clarus

Oh, this is for Mac development? Xcode 3.2 was around before the Mac App Store. You can build Mac apps with it, of course, but if you’re trying to ship them in the Mac App store, I think you need Xcode 4. Xcode 3 wouldn’t know anything about Mac provisioning profiles.

August 11, 2011 at 1:26 pm #342882

dar
Participant
@dar

I have now installed Xcode 4.0.1 but it doesn’t work. When I use Xcode 4.0.1 to open the “myappname.provisionprofile” ,it still can’t be recognized and imported.

September 18, 2011 at 2:55 am #342883

hermesdavidms
@hermesdavidms

as far as i know, for mac development, you just need the certificates that you install on keychain and that you use to codesign, its different from the ios process

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.