app store binary failure

Forums Programming cocos2d support (graphics engine) app store binary failure

This topic contains 3 replies, has 2 voices, and was last updated by  clarus 2 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
Author Posts
Author Posts
October 4, 2011 at 10:23 pm #235823

jetstream
@jetstream

just hit this error today when submitting a binary:

Non-public API usage:

The app contains or inherits from non-public classes in PieceMeCircus: NSArray, NSAutoreleasePool, NSBundle, NSCharacterSet, NSData, NSDecimalNumber, NSDictionary, NSError, NSException, NSFileManager, NSInvocation, NSLock, NSMutableArray, NSMutableCharacterSet, NSMutableData, NSMutableDictionary, NSMutableSet, NSMutableString, NSMutableURLRequest, NSNotificationCenter, NSNull, NSNumber, NSObject, NSOperation, NSOperationQueue, NSRunLoop, NSString, NSThread, NSTimer, NSURL, NSURLConnection, NSURLRequest, NSUserDefaults, NSValue, NSXMLParser, UIApplication, UIColor, UIDevice, UIFont, UIImage, UILabel, UIView, UIViewController, UIWindow CDAsynchBufferLoader, CDAsynchInitialiser, EAGLView

Invalid Code Signing Entitlements – The signature for your app bundle contains entitlement values that are not supported.

others hitting it as well:

http://stackoverflow.com/questions/7652943/non-public-api-usage-in-ios-app

hopefully this is a error on apple’s end. i fixed the app bundle error but still getting the non-public api usage error.

josh

October 5, 2011 at 12:07 am #350106

clarus
Moderator
@clarus

I had submission errors today when using Xcode 4.0.3 and the zip & Application Loader approach. It submitted fine from AL and then I got “invalid binary” in iTunes Connect (tried twice) even though that has always worked fine, and with this same app 2 weeks ago. I didn’t get any information about what was invalid.

I noticed that Xcode 4.0.3 isn’t on the main download page anymore, so I downloaded and installed Xcode 4.1 and did the Archive, Validate, Submit approach (no other changes). It validated fine and is now “Waiting for Review.”

Feels like something changed today. Maybe Xcode 4.1 is required now?

October 5, 2011 at 6:39 pm #350107

jetstream
@jetstream

fixed my issue. essentially needed to turn off the icloud option for the app id and recreate the distribution profile.

October 5, 2011 at 10:18 pm #350108

clarus
Moderator
@clarus

That’s whacked. For that, it said you were using private APIs?

Someone at Apple must have turned the chaos factor up to 11.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.